Upgrade OpenCms from 9.0.0 to 9.0.1#

  1. Download opencms-upgrade-to-9.0.1.zip at Distribution Version
  2. Unzip opencms-upgrade-to-9.0.1.zip
  3. Read file "readme.txt"

Comments and my own instructions#

1. Create backup (!)

2. There is a bug in version 15 of the guava.jar that comes with the upgrade bundle:

Feb 24, 2014 7:39:40 AM org.apache.openejb.cdi.OpenEJBLifecycle startApplication
Schwerwiegend: CDI Beans module deployment failed
org.apache.webbeans.exception.inject.DeploymentException: javax.enterprise.inject.UnsatisfiedResolutionException: Api type [java.util.Set] is not found with the qualifiers 
Qualifiers: [@javax.enterprise.inject.Default()]
for injection into Constructor Injection Point, constructor name :  com.google.common.util.concurrent.ServiceManager, Bean Owner : [ServiceManager, Name:null, WebBeans Type:MANAGED, API Types:[java.lang.Object,com.google.common.util.concurrent.ServiceManager], Qualifiers:[javax.enterprise.inject.Any,javax.enterprise.inject.Default]]
	at org.apache.webbeans.config.BeansDeployer.deploy(BeansDeployer.java:213)
	at org.apache.openejb.cdi.OpenEJBLifecycle.startApplication(OpenEJBLifecycle.java:183)
...	
Solution: Change in <opencms>\WEB-INF\lib\:

3. Copy "update" and "WEB-INF" (merge+overwrite) into existing <opencms> webapp folder
4. Delete in <opencms>/WEB_INF/lib/ again:

rm commons-logging-1.0.4.jar
rm commons-logging-1.1.1.jar
rm commons-logging-1.1.jar
5. Edit <opencms>\WEB-INF\config\opencms.properties => wizard.enabled=true
6. Open http://localhost:8080/opencms/update/ and follow instructions
7. Shutdown servlet container
8. Update solr (note: otherwise the image gallery won't work anymore!)
  • Navigate to <opencms>\WEB-INF\solr-update\
  • Pick up schema.xml + solrconfig.xml
  • Navigate to <opencm<>\WEB-INF\solr\conf\
  • Overwrite existing files with these two here
  • Edit <opencms>\WEB-INF\config\opencms-search.xml => <solr enabled="true">
9. Restart servlet container

Error "Deserialization of core data failed"#

Follow this solution, which is

  • reimport all modules org.opencms.ade.* (from ..\opencms-upgrade-to-9.0.1\update\modules\)
  • clear your browser cache
  • try again

Error "org.opencms.file.CmsVfsResourceNotFoundException"#

Fehler beim Lesen der Ressource aus dem Pfad "/opencmsPlay/system/workplace/views/explorer/explorer_fs.jsp"

URL should be /opencmsPlay/opencms/system/workplace/views/explorer/explorer_fs.jsp.
It is a rewrite problem ...

Add new attachment

Only authorized users are allowed to upload new attachments.
« This page (revision-) was last changed on 28-Mär-2017 14:37 by UnbekannterAutor